Forum Question: How Do You Sync Reminders From Mountain Lion To iOS?

I have a MacBook Pro with Mountain Lion and an iPhone 4 with the latest iOS and need some help setting up Reminders to sync. Anything I add on my iPhone doesn’t appear on my Mac and vice versa. Thanks
—–
Murph

Comments: 18 Responses to “How Do You Sync Reminders From Mountain Lion To iOS?”

    8/2/12 @ 12:39 pm

    Reminders definitely do sync between these devices. But you have to be creating the reminders on the same service.
    In the new Reminders app on the Mac, go to Reminders, Accounts. This actually takes you to your Mail, Contacts and Calendars section of the System Preferences. Check your account, like your iCloud account, and make sure you have Calendars & Reminders checked so you can create reminders with that account and the will sync with iCloud.
    Then, likewise, on your iPhone 4, go to Settings and then iCloud and make sure you have turned on Reminders there as well.
    If you are using more than one account that can sync Reminders (unlikely, but I’ll mention it), then make sure you create the Reminders in a reminders list that is part of the same account you are using on your iPhone.

      Murph
      8/6/12 @ 6:33 am

      Thanks, Gary. The accounts appear to be configured properly but they still will not sync. Anything I add on my iPhone never appears on my Mac and vice versa. I do have more than one account – I have iCloud and my Gmail configured on both the phone and Mac. I suppose I’ll be putting a call into Apple. Thanks again.

        8/6/12 @ 7:33 am

        Maybe look at your Gmail account for each device and turn OFF the Calendars & Reminders syncing for Gmail (unless you are actually using it). I suspect that one device is using Gmail and the other iCloud.

    Brian Foreman
    8/6/12 @ 9:48 am

    I’m having the same (possibly just similar) issue. New reminders that I create on my phone go into a generic list called “on my iPhone.” Unless I assign a category to them that resides in my “.Mac” folder the items will not show up on my MBP. I’m curious if there is a way to move them over without individually assigning each to a “.Mac” folder?

      8/6/12 @ 10:46 am

      If they are going to “on my iPhone” then they are being saved on just your iPhone, and not iCloud. You need to check your iCloud settings. Move over or re-create any reminders that are “on my iPhone” to a list that is in iCloud. Then delete the empty “on my iPhone” lists so they won’t get used again.

    Brian Foreman
    8/6/12 @ 12:24 pm

    Thanks Gary. I went into settings on my phone and turn reminders off, choosing to “keep on my iphone.” Once I turned them back on they appeared on my desktop. Now my generic list is on synced on both.

    Wifey Dux
    10/9/12 @ 12:41 am

    Hey there,

    I was having a similar issue and the not-syncing ended up being because I didn’t have push notifications enabled on my phone for mail. Once I set this up to push the syncing happened beautifully (of course I don’t know what this will do to my battery life…)

    Tammy
    10/13/12 @ 8:56 am

    Hi there,
    My reminders is syncing between my Ipad and iPhone but anything I write on my mac does not sync to the ipad or iPhone. Everything is on in iCloud so Im not sure what the disconnect is… Please help :)

      10/13/12 @ 9:52 am

      Just check and recheck everything. Check your iCloud settings on your Mac. Check your accounts in the Reminders app.

        Tammy
        11/3/12 @ 11:09 am

        I have rechecked everything and everything is turned on to sync including iCloud.

          11/3/12 @ 11:52 am

          The next step would be to get first-hand help from an expert: Apple Genius Bar, for instance.

    Mike B
    10/31/12 @ 5:43 pm

    Using Mountain Lion (and IOS5 on the iphone – I like Google Maps) I want to sync Reminders, but not all my calendars. It seems you have to choose to sync both. Is there a way to sync reminders only? Thanks

      10/31/12 @ 6:16 pm

      In iOS 6 you can. I guess you can’t in iOS 5 because reminders used to be a part of iCal on the Mac.

        Mike B
        11/6/12 @ 5:34 am

        Thanks.

    Thierry
    12/6/12 @ 3:06 pm

    There is definitively a bug. I want my calendar to not be synced through iCloud since I use my Gmail calendar. But I want my reminders to be synced through iCloud. And there is no way to set this up consistently through May OS X Mountain Lion (ML) on my Mac + iOS 6 on my iPhone. You can easily see there are inconsistencies: on iOS, the settings for Google mail do not provide a Reminder entry (only a Calendar one), and the settings for iCloud have both entries; whereas on ML the settings for Google Mail provide a unique Calendar+Reminder entry, and the settings for iCloud too. So there is no way I can just obtain the simple result I wanted.

    Now, to come back to messages here above: it is wrong it is an iOS6 versus iOS5 feature. Moreover, while you can write mails or define calendar event by specifying the account, there is no way to link a reminder to an account.

    I believe this has to be fixed by providing a neat separation between Reminders and Calendars (and mail accounts), on all devices and OS (ML, iOS6, and iOS5 – since iPad is still on iOS5).

      12/6/12 @ 5:06 pm

      Right. Reminders is a feature of iCloud, but not a feature of Google. There’s no way to tie a Reminder to an account because Reminders are only an iCloud thing.

    Steve
    2/10/13 @ 11:35 pm

    Here’s the deal. Don’t use the “On My iPhone” list for reminders because that’s the only place you’ll find those reminders. Type those in on your Mac to the standard “Reminders” list or create new lists in the left panel of the OSX version or in the settings page of the iPhone version. Delete the “On My iPhone” list and you’ll find that all reminders now sync.

    Tom Crofford
    2/15/13 @ 6:28 pm

    I had a problem where a list I created and set reminders for would not sync correctly to my iPhone. That list works to my Mac and iPad.

    After reading the comments here, I disabled Reminders on iCloud and chose to delete the reminders from the iPhone. I then re-enabled Reminders on the iPhone.

    That sequence fixed the problem. I would not have thought to do that without having read everyone’s comments.

    Thanks for everyone’s input on this forum.

Comments Closed.