Forum Question: How to enable automatic connection for internet sharing?

I have an iMac directly connected to my DSL service through Ethernet, and have enabled internet sharing for it via System Preferences.
I can connect to my iMac automatically via wifi using my iPhone and my iPod touch without having to select the connection and log in each time; it just works.
However, I also have a MacBook Pro, and I also want to be able to connect to the internet in the same way (getting the internet connection shared from my iMac) without having to manually select the name of the connection and log in each time.
This functionality worked when both my iMac and my MacBook Pro were running Snow Leopard. Unfortunately, since installing Lion on both of these devices, every time I wake the MacBook Pro from sleep, I need to reselect the connection and manually log in.
I have searched through postings on various Mac-related forums and it seems that others have experienced the same problem, but I have not seen a clear solution posted yet. I have tried various things using the Preferences on the MacBook Pro in an attempt to have it remember the connection to the iMac, but so far, nothing has worked.
Can anyone provide me with the steps necessary to enable my MacBook Pro to automatically use the Internet Sharing provided by my iMac?
If not, is this a known bug with Lion?
—–
Richard Fuhr

Comments: 4 Responses to “How to enable automatic connection for internet sharing?”

    9/26/11 @ 2:32 pm

    Have you tried removing the network from the list of preferred wifi networks, and then adding it again?

      Richard Fuhr
      9/26/11 @ 3:05 pm

      Yes, I just tried that. I removed the network and then added it back in. I made sure I checked the box that said “Remember networks this computer has joined” in the general preference pane section and also I made sure I checked the box that said “Remember this network” in the specific dialog box for logging in to my iMac-provided network. However, despite, that, when I did the test of putting the MacBook Pro to sleep and awakening it, I still had to manually select my iMac-provided network and provide the password.

    Richard Fuhr
    9/27/11 @ 2:11 pm

    I think that I have answered my own question; I went back into Preferences and saw that there were actually two entries for my preferred network. I deleted one of them and made the other one top priority, and now the MacBook Pro is automatically reconnecting to the iMac after awakening it from sleep.

      Richard Fuhr
      9/27/11 @ 2:16 pm

      PS – Gary actually had the right answer all along; apparently I did not dig deep enough into the list of preferred wifi networks and did not realize that there were two entries in there that pointed to my iMac.

Comments Closed.