Forum Question: iCloud Isses With Calendar and Contact Sync

I have some questions with iCloud syn with Calendar and Contacts:
Calendar: on my iPhone every entry duplicated as I had both iCloud and from my Mac was checked off. So only way I found to address this is un-check all calendar “from my Mac” and only check “iCloud”. That appears to have addressed it, but I thougt “from my Mac” and “iCloud” are suppose to sync and so on the iPhone only have one item appear.
Contacts: My contacts appears to have synced to iCloud; however if go to preference in contacts in my Mac and “enable” iCloud, everything duplicates. I am curiOS to why that happens. I have it un-checked.
—–
Ahsan

Comments: 13 Responses to “iCloud Isses With Calendar and Contact Sync”

    10/18/11 @ 9:22 am

    Right. You don’t want to sync both calendars. If you use iCloud, there is really no reason to have an “On My Mac” calendar. Your iPhone and iTunes sees them as two separate things.
    Same thing seems to be happening to you for contacts. You’ve got one set “on your mac” and one set in iCloud. You only need the iCloud set. So get rid of the contacts on your Mac. Maybe export or back them up first.

      Adnan
      10/26/11 @ 3:18 pm

      How do I get rid of the contacts “on my mac”?

        10/26/11 @ 3:22 pm

        Go to the groups page, select “All on My Mac” to see a list of those contacts, and then select those contacts and delete them.
        You can also disable all other Address Book Accounts in the Address Book Preferences, so you can only see “on my Mac” contacts.
        You may want to export them all first, as a backup.

    Ahsan
    10/18/11 @ 1:15 pm

    Thanks Gary.
    Another Question: I have multiple iphones in service. For some reason only my iPhone seem to be “offline” in find my iPhone service. It used to work before. But now it continues to be off line, i.e. it does not locate it. The option on my iPhone “find my iPhone” is on. I even turned it off, and back to on again. Any clue?

      10/18/11 @ 1:21 pm

      No, sorry, no tips there. Just have to play with it.

    Joyce
    8/21/12 @ 11:58 am

    May not be an iCloud issue but having put Mountain Lion on my Mac, I cannot edit or delete any contact and cannot delete the On My Mac account or even have it not show. I can add contacts but they do not populate to iCloud.
    Is a reinstall of Mountain Lion a (or the only) solution?
    Thanks so much!

      8/21/12 @ 12:11 pm

      Just check and recheck your settings — you probably don’t have iCloud turned on for contacts.

    Joyce
    8/21/12 @ 1:44 pm

    Turned on in System Preferences and Contacts preferences. Both in the Cloud and on my Mac show up in the Contacts book. There is no way for me to edit or delete a contact — the book looks different here than on my iPads or MacBook where there are icons to click to edit or delete.

      8/21/12 @ 1:53 pm

      The Contacts app on a Mac does look different — it is a cursor-driven app, instead of a touch-screen app.
      Perhaps you are expecting contacts “On My Mac” to appear in iCloud — they won’t. Drag and drop to move them from the “On My Mac” contacts list to your iCloud one.

    Joyce
    8/21/12 @ 2:07 pm

    Not the problem. On my Mac I can only add or send a contact whether from “On my Mac” or “iCloud” There is no way to edit or delete in either set of contacts. For example, I have one contact whose last name has changed. There is no way on the Mac to do that. I have to change it on another platform, or in the Cloud, I imagine, to have it changed on the Mac iCloud and no way to change it at all on the Mac side. I tried dragging/dropping from On the iCloud to On my Mac and no go either. Succinctly, in the Mac Contacts program I don’t have any way to edit or delete *any* contact anywhere. All other platforms including the MBP with Mountain Lion there’s an edit button and drop-down Edit Delete Card. Here on the Mac there’s no edit button and Edit card and Delete card are greyed out for both On my Mac and in the cloud.

      8/21/12 @ 2:54 pm

      So are you saying there is no edit button, or that there is an edit button and it is grayed out? (you say both, so I’m confused).
      In Contacts there should be an Edit button at the bottom of any contact. Just click that and you can edit the fields in the contact.

    Joyce
    8/22/12 @ 9:04 pm

    No edit button on the bottom of the contact page and “edit” and “delete” are greyed out in the drop-down menus at the top of the screen. I.E. no way at all to either edit or delete a contact on the Mac. iPads, MBP and iPhone all work properly.

    Weird, eh?

      8/22/12 @ 9:11 pm

      That’s odd. I can’t tell anything else from here, but you should get that in front of an expert so they can take a look. Probably something obvious, you know?

Comments Closed.