Forum Question: “Quartz Extreme Required” message

My wife has been using iMovie’09 literally daily on her MacBook Pro w/Snow Leopard. It’s been working fine. Tonight iMovie won’t open, giving her the following message: “iMovie requires a graphics card that is compatible with Quartz Extreme. One or more of your graphics cards does not support Quartz Extreme.” Can anyone suggest anything that we might do to get her back in business? Thanks.

— John Russell

Comments: 27 Responses to ““Quartz Extreme Required” message”

    11/28/09 @ 9:20 pm

    Try changing the screen resolution to something different, and then back again. See if that fixes it. If not, try logging off and back on. If not, try restarting. If the problem persists, perhaps a visit to the Genius Bar.

      Belinda Callander
      6/9/11 @ 5:59 am

      It worked, thank you!!!!

      Louise Courtney
      6/22/11 @ 2:27 am

      Thanks, worked for us too. Thank the InternetGod for Google!

      David Muro
      4/22/12 @ 3:33 pm

      Thanks Man!!! Itt Worked Just Fine :D

      Mrs Dildo
      6/20/12 @ 2:56 pm

      It worked!!

      10/20/12 @ 8:54 am

      You are the GENIUS. It still works!

    John RusselL
    11/28/09 @ 11:37 pm

    Gary, my wife thanks you many times over! The first suggestion, changing the screen resolution twice, fixed the problem.

      John Borgmeyer
      2/16/11 @ 5:32 pm

      Hey Thanks!!! This worked for me as well, I’m on Snow Leopard 10.6.6 Macbook Pro trying to use Final Cut Express and/or Imovie and I was getting this as well. I think it was caused from hooking up a dual display. Thanks again for the (temporary) fix!

    john Mccoubrie
    1/14/10 @ 12:15 pm

    i have encountered the same problem, but as for me when i go to system preferences/display it only shows 1280×800 with no other options.

    Also i have been told to switch my colors from millions to thousands and back again i can only find a millions selection

    Please help,
    thanks john

    *i have imovie08 though*

      1/14/10 @ 12:25 pm

      Are you using Leopard or Snow Leopard? It sounds like the System Prefs are only showing you “recommended resolutions” — look for the option to have it show all.

    James Parsons
    11/23/10 @ 7:11 pm


    thank you so much for your suggestion, changing the resolution down and then back up again worked fine for me.

    Thanks again


    SIgurd Magnusson
    2/15/11 @ 4:04 am

    Wow, this bug has been around for years. I got a new Macbook Air and this bug still crops up in 2011; but yes, changing screen resolution is the solution.

    2/22/11 @ 4:25 pm

    Thanks Gary!

    Just figured out that if it doesn’t work when you change the resolution then try to open iMovie with smaller resolution and then switch back to the normal one ;-). Tricking out Mac OS X Snow Leopard :D!!

    7/3/11 @ 7:14 pm

    I feel very stupid, but where in the system preferences can you change the resolution? I can’t seem to find it.

      7/3/11 @ 7:40 pm

      The display resolution? System Preferences, Displays, Display.

    Dnero Sucio
    7/27/11 @ 6:34 pm

    i’m trying to install Logic Pro 9 to a G5. i followed the advice about changing the resolution. but now its saying that i need a “Quartz extreme compatible video card” and that “the current graphics card” i have doesn’t support Logic. the osx is up to date, i have the proper version of quicktime….no results.

      7/27/11 @ 6:42 pm

      Well, it probably means that you can’t run Logic Pro 9 on your Mac. But for details I’d ask in a Logic forum or site.

        Dnero Sucio
        7/27/11 @ 7:58 pm


    10/26/11 @ 10:11 am

    guys i tried changing the resolution, restart, logout …..
    the problem persists its still giving the same message

    1/3/12 @ 6:59 pm

    whoha changing the screen resolution to lower and then higher again worked (I think that’s ****** up)

    Thank you! :-)

    4/28/12 @ 12:57 am

    Hi, I’m using MacBookPro Lion 10.7.2 when i open imovie and get this message “iMovie requires a graphics card that is compatible with Quartz Extreme. One or more of your graphics cards does not support Quartz Extreme.” plz help.

      4/28/12 @ 8:10 am

      Did you try some of the suggestions above? Read the first comment and try that.

    5/1/12 @ 6:12 am

    I am hacking same problem. Have tried all the suggested solutions without luck. I am using a Mac mini and connecting remotely by iPad and MacBook.

    7/4/12 @ 2:50 am

    Thank you indeed! Worked!

    7/20/12 @ 1:52 am

    You just help me!!
    I am using a Macbook. (I know he’s old but we get him from school.)

    8/18/12 @ 3:04 am

    I am getting this same issue, I used safe mode and its appears to of disabled most of the computers systems including its audio inputs/outputs as well as this-and changing the resolution does nothing.

    11/25/12 @ 1:56 pm

    thanks again – worked for me !

Comments Closed.