MacMost Q&A Forum • View All Forum QuestionsAsk a Question

How Do I Turn Off the File Extension “filename.pages.pdf” To Only “filename.pdf?”

We regularly make proposals at my office in either Pages or Numbers and, once complete, we Command+P > PDF (bottom left) > Send in Mail. The annoying thing is the extension for the filename reads “ProposalFromEric.pages.PDF”. I say annoying, however, some clients Windows machines reject the file because of that extension. Is there any way to have it export as “ProposalFromEric.PDF” without having to first save it to the Desktop > alter name > attach to email?

Thank you,
Eric
—–
Eric

Comments: 2 Responses to “How Do I Turn Off the File Extension “filename.pages.pdf” To Only “filename.pdf?””

    4 months ago

    The “Send in Mail” shortcut is just appending .pdf to the end of the filename, which I assume is “ProposalFromEric.pages.” One thing you can do is to create your own custom Send in Mail script in Automator and add it to the Print dialog. But that takes some Automator know-how and I’m not sure what your skill level is with that.

    You could just simply export the file as a PDF from Pages. Then attach the file as a message to an email. When you name the export, just don’t include the .pages part.

    There is also the Share, Send a Copy option. That is just as quick as using Print, Save as PDF. And it doesn’t seem to include the .pages in the name.

    You could also just name your file “ProposalFromEric” and leave off the .pages. You don’t technically need the file extension and many people don’t use them for things like Pages documents.

    Eric
    4 months ago

    Thank you Gary.
    Automator, though friendly, is too steep of a cliff for me to make something without instruction. The .pages is automatically added to the filename without my intervention. I was assuming this was because I have Finder Preferences > Advanced > Show all filename extensions checked. However, if I don’t have that checked it hinders me elsewhere. I will try using the Share option because you are correct, the .pages is not present in the filename when the email is composed. TY

Comments Closed.