MacMost Q&A Forum • View All Forum QuestionsAsk a Question

How Do I Stop Mail From Appearing On All Desktops?

When Mail opens is appears on 3 desktops, all are identical. How can I change this?

—–
Ed Robidoux

Comments: 3 Responses to “How Do I Stop Mail From Appearing On All Desktops?”

    2 years ago

    So I assume what you mean is that you are using Mission Control and have three desktops that you switch between, correct? And when you launch Mail, you can see the same Mail window open in all three desktops?
    Look for Mail in the Dock. Control+click it and look at the context menu that appears. Look in the Options submenu in there. It is probably set to Assign To “All Desktops.” Change that to “None” and you should be set.

    Ed Robidoux
    2 years ago

    Gary, thanks for the quick response. I changed the context menu to ‘None’ and rebooted but I’m still getting mail on 3 desktops.

    2 years ago

    Ed: No need to reboot. The change should happen right away. Did you check again to see if it is set to “None” still? Maybe try assigning to “This Desktop” to see if it then appears only on the current desktop and not the others, as an experiment.

Comments Closed.