Forum Question: How do I transfer pictures from Canon Rebel XT to iPad

I have never been able to transfer photos from my canon rebel xt to my ipad with the camera connection kit. When i remove the SD card from a compact camera and use the camera connecton kit piece it works great. Because the memory card is too big for this I have to use the USB piece and nothing happens.
—–
Andrea Szerlag

Comments: 26 Responses to “How do I transfer pictures from Canon Rebel XT to iPad”

    10/7/10 @ 5:53 pm

    Did you switch the camera into the mode that allows it to transfer photos? The same mode you would use to transfer photos from it to a computer?

    Andrea Szerlag
    10/8/10 @ 6:12 pm

    Yes I have and nothing. I also tried the compact camera thinking something might be wrong with the USB camera connection piece so I tried the small compact camera and it worked great. So there must be something “missing” between the rebel and the connection piece. Any ideas??

      10/8/10 @ 6:14 pm

      No ideas. And I don’t have one to test. But if the SD card transfer works, then why use the USB method anyway? It would be slower, and use battery power.

    Andrea Szerlag
    10/9/10 @ 7:35 am

    I can’t use the SD card piece because the rebel XT has a larger card and it won’t fit in the slot.

    Thanks for responding, I keep searching.

      10/9/10 @ 6:15 pm

      Searching Google for “iPad camera connection kit and Rebel XT” comes up with a lot of info. Seems that that camera isn’t on the list of compatible cameras. But at the same time, there are mentions of it working anyway. It might have to do with the format that you have the camera set to. Since I don’t have that camera I can’t really help much there.

    forkboy1965
    10/10/10 @ 2:36 pm

    I don’t know why it should matter, but try an experiment. Shoot a couple of images with the camera in RAW only and try to transfer them to the iPad with the USB cord, etc.

    Delete those images and shoot in JPEG only and try again, deleting the images once you’re done.

    Finally, shoot in RAW+JPEG and try yet again.

    It may be possible that the iPad simply doesn’t recognize the proprietary RAW files and if this is the case then the JPEG only images should transfer.

    The only other thing that comes to mind is the possibility the camera or the iPad doesn’t have enough juice/power to send/receive in this scenario. I know it sounds pretty weird, but I’m trying to think outside the box here.

    Dimitri
    10/23/10 @ 11:24 am

    I’ve run into the same problem. It begins to recognize it and then stops. Or it will see the photos and once you begin to transfer it would stop. I must say it’s highly annoying. A usb card reader doesn’t work because it doesn’t have the juice to power it. Hopefully I can find a solution.

    Dimitri
    10/23/10 @ 12:29 pm

    Well I’ve found the answer to my problem was that I was the USB cam
    Ble I was using. I decided to grab a different cable and I ended up grabbing a USB cable for my gamin gps and it works with out a problem. Hope this helps.

    Karen
    11/17/10 @ 8:54 am

    I have the same problem with my canon rebel eos, iPad will not recognize, frustrating!

      Anthony
      8/28/11 @ 8:29 pm

      Had the same problem with my canon xti 400D.
      I have over 200 photos on my IPad .
      You need to use the right cable .
      The transfer cable that came with your camra should work.
      It works for me I hope it works for you.
      The Fonz 5050

    Roberta
    12/21/10 @ 7:19 pm

    In my case it has downloaded around 15 pics and it just stopped. vERY frustrating…..

    Michael Young
    12/27/10 @ 1:48 pm

    I like it when somebody without iPad, without Rebel, without any knowledge about CF and SD cards tries to answer a technical question.

    Michael Young
    12/29/10 @ 12:46 pm

    From this page: http://www.usa.canon.com/cusa/support navigate to you camera and check latest firmware release and compare to what you have. For XT it is 1.0.3, for XTi it is 1.1.1 and so on. If necessary download latest version and update your camera. Use fully charged battery for this process. Now set your camera to a protocol that is known to iPad: on your Rebel press Menu and select last tab, scroll down to Communication and select “Print/PTP”. Press menu again and turn the camera off. Connect to your iPad using connection kit. Your photo app should now see your pictures on the camera. Some USB cables may have problem causing interrupted transfer. If you encounter this try different cable.

      Andy Watson
      6/14/11 @ 1:18 pm

      Genius solution. Thank you Print/PTP works really well.

      Michelle
      7/8/11 @ 1:33 pm

      Thank you so much. It worked perfectly without the updated firmware. I’m glad their are people like you who know so much about computers or I would just lose my mind with frustration.

      tfneva
      9/17/11 @ 6:04 pm

      Thanks! The Print/PTP solution worked, but not without some difficulties. My experience: Checked Canon Rebel XT firmware; I already had latest. Checked that camera was set to Print/PTP; already set to that. I changed to PC Connect, and made some progress because at least my Mac recognized the camera, then an EOS utility was automatically installed, but that is a poor utility and Picasa still did recognize. I switched back to Print/PTP on camera, then had to restart my Mac. Now it works.

      Tabby Marx
      4/26/12 @ 10:50 pm

      Fantastic, thanks SO much!!!

    Harjit khurana
    2/25/11 @ 9:13 pm

    From camera connection kit I can transfer photos on my I pad from smaller cannon camera-but I can not do it from my cannon sx15is any help

      Harjit khurana
      2/25/11 @ 9:15 pm

      Sorry it is cannon sx35 is not sx15is

        2/25/11 @ 10:36 pm

        Is it on the list of supported cameras? Sounds like the kit just doesn’t support the format used by that model. Have you tried using the SD card connector instead?

    David levy
    3/27/11 @ 1:22 pm

    Michael Young’s suggestion (see above) worked for me! Once I set the the communication on the Rebel XT to “Print/PTP” it worked without a hitch. Another workable solution is to use a SD card in an adapter, which will work in the Rebel XT!

      tfneva
      9/17/11 @ 6:09 pm

      Canon does not use SD (Secure Digital); it used CF (CompactFlash). It is a larger card, and does not fit in an SD slot.

        Paul
        4/1/12 @ 7:14 am

        Canon does not use SD card? That’s very strange, cause my T3i does!

          Tom C
          4/9/12 @ 1:38 pm

          The Canon XTi/400D (I have one.) uses a Compact Flash card and adopted the smaller SD card in later models, perhaps when the storage capacity of the SD increased.

    Wendy mc
    7/14/11 @ 8:48 pm

    I switched to print/PTP and it no longer gives me the unsupported message but I just get a blank screen under the camera tab with no pictures or option to import. Suggestions?

    AL
    8/23/11 @ 1:23 pm

    Thanks to Michael Young for his answer works great!

Comments Closed.