MacMost Q&A Forum • View All Forum QuestionsAsk a Question

How Do I Turn Off the Virtual Keyboard When I Unlock the Screen?

When I lock my screen, or select sleep, why does a virtual keyboard appear on my screen when I attempt to resume working on my computer? The only option I have is to use the mouse and type my login password. I cannot use the laptop keyboard or my wireless keyboard. This is a real nuisance and I’d like to know if I can disable this virtual keyboard? Thank you.

Why does a virtual keyboard appear on my screen when I attempt to log back into my laptop after locking or putting the screen to sleep? How can I disable this?
—–
Terry Homick

Comments: 6 Responses to “How Do I Turn Off the Virtual Keyboard When I Unlock the Screen?”

    1 month ago

    The setting for having the Accessibility Keyboard on the login screen is in System Settings, Lock Screen. Then click Accessibility Options. It is the Accessibility Keyboard setting.

    Do you see it turned on? If so, don't turn it off just yet. Having the Accessibility Keyboard on the login screen shouldn't affect whether your physical keyboard works or not. If your keyboard isn't working on the login screen at all, then you have a problem. And now if you turn off the Accessibility Keyboard on the login screen, you have no way to log in to your Mac.

    So first figure out why your physical keyboard isn't working on the login screen. Do you have other issues with your keyboard as well? Does it work on the login screen if you simply wait a few more seconds, does the keyboard work then? If you can't get the physical keyboard to work on the login screen, call Apple Support and work with them on this.

    Terry Homick
    1 month ago

    When I need to leave my office, I either lock the screen or if I know I'll be awhile, I'll choos sleep. When I return and hit the return key to activate my laptop, a black virtual keyboard is centered in the middle of my screen. The finger print log in option is disabled, and the laptop keyboard is not functional. I have to use the mouse and type in my password. I have a second Mac, and I can leave it in the locked or sleep position overnight and this virtual screen never appears.

    1 month ago

    Terry: Probably best to call Apple Support and figure out what is going on.

    Larry
    1 month ago

    Twice I have been stuck away from home without a working physical keyboard. Each time I've been lucky to find someone to lend me a keyboard to login. This is particularly troublesome with USB wireless keyboards. They don't always pair with a Mac on startup. No more. I've turned on the virtual keyboard and left it on. I would have to have both a dead trackpad and a dead keyboard at the same time. Upside: this has been extremely effective. The problem has never repeated. Downside: none.

    Terry Homick
    4 weeks ago

    I hever have a problem logging in during a power up. The wireless and laptop keyboards work flawlessly. It's only when I want to log back on after having locked the screen or placed the laptop in the sleep mode, that the black virtual keyboard appears. Other options on the screen include, restart, cancel, and shut down. I usually select restart. I guess I'll have to take this up with Apple. Thanks! I am grateful for all of your efforts!!

    Terry Homick
    4 weeks ago

    I've been doing some research and I am all but 99% certain that if I turn off the Accessibility Keyboard, the problem will go away....

Leave a New Comment Related to "How Do I Turn Off the Virtual Keyboard When I Unlock the Screen?"

:
:
:
0/500 (500 character limit -- please state your comment succinctly and do not try to get around this limit by posting two comments)