MacMost Q&A Forum • View All Forum QuestionsAsk a Question

How Do Insert a Youtube Video As a Link and Not an Image Into Pages?

I am trying to insert a youtube link into a pages document. I just want the link to appear as a youtube link (https://youtube.com/watch?v=LlXVikDkyTg) – but instead the whole video is appearing. How do I get it just to appear as a link?

I don’t want the video picture to appear. I need to print out the document and printing images wastes ink. I just need the link to appear as text.
—–
Sheli Berger

Comments: 7 Responses to “How Do Insert a Youtube Video As a Link and Not an Image Into Pages?”

    1 year ago

    That is a new feature of Pages, the ability to insert a YouTube video. If all you want is a link, then you can just add some text, select it, choose Format, Add Link, Webpage, and enter the URL.

    If you want to simply paste the text of a link, and not have it become a link, or use the link as the link text, then choose Edit, Paste and Match Style instead of Edit, Paste.

    Sheli
    1 year ago

    Thanx, I also found that if you go into preferences on pages it gives you the option to uncheck “paste YouTube and Vimeo links as web videos” – I unchecked this and its is now normal.

    Charles Reich
    1 year ago

    I open TextEdit and drag the Link URL into the TextEdit page. It creates a live link not with the HTTP but with the topic/description of the URL. Copy/Paste this live/link, blue, URL topic into your
    ‘Pages document.

    Larry Whited
    9 months ago

    Sheli…..Thanks much for your question AND for your own reply to your question. This is the simple and clear shortcut that I was having difficulty and frustration in finding. (For those searching for the “Preferences” tab, look not on the working page’s toolbar, but instead click on the main “PAGES” tab up by the Apple icon at the top left of the desktop screen.)

    Lucy Neatby
    5 months ago

    Thank you everyone – this was driving me crazy. Great info on finding the Preference setting too.

    Mara
    5 months ago

    Thank you! I spent so much time trying to find a solution on internet. And you figured it out – right in preferences.

    Karen Wagner
    4 months ago

    Sheli, thank you so much. I found this new “feature* infuriating.

Comments Closed.