Forum Question: External Hard Drive Won’t Eject Normally

I do manual, not automatic, Time Machine backups, while running Lion and using an external hard drive attached to my iMac.
When the backup completes, I right-click on the icon representing the hard drive and select ‘Eject G-Drive Mini’.
However, then I get the message ‘The disk “G-Drive Mini” wasn’t ejected because one or more programs may be using it’
It then gives me the option of doing a ‘Force Eject’ of this drive, which I then sometimes do.
But my question for the forum is: how can I find out what program may be using the G-Drive Mini? Since it is done with the time machine backup and since I have closed that preference pane, I doubt that Time Machine is still using the external drive. But how can I find out for sure?
—–
Richard Fuhr

Comments: 28 Responses to “External Hard Drive Won’t Eject Normally”

    8/22/11 @ 1:58 pm

    This has been reported by many people.
    I believe it has to do with Spotlight indexing the drive — a new feature of Lion where you can use Spotlight to search Time Machine backups.
    So it is your system using the drive. Best to just leave it connected.

      john
      6/8/12 @ 9:08 pm

      Leave it connected? That’s all you have?

    Richard Fuhr
    8/25/11 @ 9:23 am

    Indeed, it is Spotlight indexing the drive. I checked via the following Terminal command on August 22

    sudo lsof | grep Volumes | grep Spotlight

    and saw many entries involving mds ( which is the metadata server program that manages the indexing) and

    /Volumes/G-DRIVE Mini/.Spotlight-V100

    I have checked from time to time, and the indexing has been going on continuously ever since then, including now, which is three days later.

    Is this normal? Should I just let it continue, even if it takes a few more days? What have others’ experiences been?

      8/25/11 @ 9:25 am

      Yes, I believe it is normal. I think Lion has new abilities to be able to search your Time Machine backups that weren’t there before. But it will take a while for it to index your entire backup drive. After that, it may use the drive less as it only has to deal with updates.

      John A
      7/3/12 @ 2:53 pm

      Richard, thank you for the “lsof” cmd! I thought I hosed my external disk when I couldn’t unmount, force eject, etc, then the labels reverted to “sdisk…”. I finally pulled the USB cable and powered it off in despair. Reconnected it a week later, labels were back, Disk Utility’s repair worked on 1 of 2 partitions, but now I know it is/was Spotlight accessing the 2nd partition.

    Richard Fuhr
    8/25/11 @ 9:30 am

    Gary, Thanks for your quick reply; I appreciate it.

    In this case, the drive being indexed has a capacity of 499.76 GB of which 415.82 GB have already been used, which could explain the lengthy time needed to perform the indexing. I will keep the drive connected and let the indexing continue.

    Mr Anthony Cotton
    8/25/11 @ 12:50 pm

    I have 3 external hard drives. My Book, i always leave that one alone. WD My Passport i have no trouble with that one. The Iomega i do have trouble with that one. Warning comes up saying 1 or 2 applications may be using it. The main one is when emptying trash or transferring data. I do not use Time Machine and i have Snow Leopard.

    Lillian
    1/1/12 @ 9:14 pm

    I have 10.6.8 on MacBook Pro. When I try to eject my 1TB external hard drive, I get the error message “one or more programs may be using it.” When I tried to eject it from Utilities, it said that “it could not be unmounted.” What’s the safest way to unmount it? Can I just shut down my laptop and then turn off the external hard drive after the computer is shut down?

      1/1/12 @ 9:43 pm

      Right. If you can’t figure out which app is using the drive, then first try quitting all of your apps. If that doesn’t work, then just shut down, disconnect the drive.

    Tiffany
    7/12/12 @ 2:06 pm

    Hi all,
    I have a 3tb external hd that I use for time machine and photo/video archive. It’s hooked to a macbookpro that I often take to off-site locations to work. Therefore, I must eject my external drive often. Will I need to shut-down every single time just to get this drive ejected?! Or is there an easier way without damaging the drive. (I’m getting the “one or more programs may be using it” error when I try to eject.) Thanks!

      7/12/12 @ 2:18 pm

      Shut down? You should never have to shut down. Just drag the drive to the trash, or Control+click it to eject it. Either method removes the drive. Once it disappears from the finder you can unplug it safely.

    Joy
    7/21/12 @ 12:44 am

    I have the same problem with a WD drive that I only use for pictures – not Time Machine or any application at all. Nothing I do will eject the disk, literally nothing – and I’ve even dug around and tried using Terminal commands without success (admittedly I’m no expert). If I try to restart or shut down the MacBook Pro (running Snow Leopard), it hangs and I have to do a hard restart. Tried using Disk Utility to repair, but it just hangs. I was able to unmount one of the partitions after using the killall Finder command, but the other partition is ‘stuck’. Can’t drag it to the trash, can’t Ctrl + Click. No error messages, it just doesn’t eject. If I unplug it, I get the you’ve ejected the the disk improperly etc. message. When I run Disktool I get this:

    ***Disk Appeared (‘disk1s2’,Mountpoint = ‘/Volumes/Passport 2’, fsType = ‘hfs’, volName = ‘Passport 2’)
    ***Disk Appeared (‘disk1s1’,Mountpoint = ‘/Volumes/Passport 1’, fsType = ‘hfs’, volName = ‘Passport 1’)
    ***Disk Appeared (‘disk1’,Mountpoint = ”, fsType = ”, volName = ”)
    ***Disk Appeared (‘disk0’,Mountpoint = ”, fsType = ”, volName = ”)
    ***Disk Appeared (‘disk0s1’,Mountpoint = ”, fsType = ”, volName = ”)
    ***Disk Appeared (‘disk0s2’,Mountpoint = ‘/’, fsType = ‘hfs’, volName = ‘Macintosh HD’)

    The disks labeled Passport 1 and Passport 2 are the ones on the WD drive that I’ m having issues with. The only other drive is the Macintosh HD – so what are those other disks with no volume name?

    When I try to run lsof, it keeps telling me that the volume (passport 1 or passport 2) doesn’t exist, so I can’t tell what process it still using it.

    It’s just a copy drive and I’d really like to just erase it and start over, but can’t get to that point! Any ideas?

      7/21/12 @ 7:35 am

      How is it formatted? Maybe erasing and reformatting again as Mac OS Extended (Journaled) will help if it isn’t formatted as such now. Maybe don’t use partitions next time either — just one drive since you only use it for one thing anyway.

    Joy
    7/21/12 @ 4:07 pm

    Thanks Gary, I’ll give that a try. I finally pulled the disk and will hopefully be able to just erase it in Disk Utility. . .Not exactly sure how it’s formatted at the moment. And yes, I’m 86ing the partition. Had some fancy idea originally why I did it that way, but doesn’t seem to be relavent anymore.

    Lily
    7/21/12 @ 11:34 pm

    Both iomega & lacie ext Hd’s not ejecting. Have quit all progs, computer will not shut down, says Finder is busy (w/the HD’s which are hanging in copy mode). They are both formatted Mac OS extended – any further suggestions? Thanks

      7/22/12 @ 9:08 am

      Sounds like something else is going on — maybe some software you have installed is still accessing them. Do you have any hard drive monitoring or cleaning software? Anything like that?
      Try shutting down. Then disconnect. Then restart without them connected. Then reconnect them and see if they behave normally again.

    Joy
    7/22/12 @ 7:42 pm

    After working on this for three days (seriously dropping another $100 would be easier) it occurred to me that it might be related to the Trash. Every time I plug in that drive, things show up in trash – maybe there was a delete event that is/was getting it hung up for some reason? I’d deleted a ton of photos just before all this started happening.

    BTW Gary, if Disk Utility is telling me what I think it’s telling me, then it was originally formatted as a DOS partition. I think when I first got the drive I needed to pull files of my PC to the Mac and since the Mac could see DOS, etc. But I plugged it into my PC today and while it acknowledges the existence of the ‘new hardware’ it never shows up under My Computer so I couldn’t access it.

    Tried to delete and reformat last night and all it did was hang the MBP and get it really hot.

      7/23/12 @ 8:10 am

      Maybe give it another try reformatting (unmount the partition in Disk Utility and simply select the drive itself and see if that works). But maybe it is time to just get a new one, especially if this one is smaller than a new one you might get anyway.

    Joy
    7/22/12 @ 8:28 pm

    Okay, so I can’t erase the drive and I can’t repartition the drive. I can access it and copy stuff from it, but obviously something is deeply wrong. The only way I can unmount it without hanging my whole system (which then requires a full push the power button to shut down) is to simply unplug it. I really like to use this drive as a back up for my photos and to use it to edit photos before copying them back to the main back up drive. I know that the .fseventsd file or volume is causing me issues, but I can’t seem to figure out how to fix it. Should I just call it dead and get a new one?

      7/23/12 @ 7:55 am

      Could be something wrong with the drive. When you say “can’t erase the drive” — what do you mean? What are you trying and what is the result (error message, etc).

    Joy
    7/29/12 @ 11:11 am

    Definitely something wrong with the drive. I’ve tried using every option under Disk Utility to reformat (it hangs on unmounting – then becomes unresponsive) or erase (hangs on unmounting) the drive. Dug around my system log and found that every time the 2nd partition was accessed, fseventsd not responding or out of sync with volume. I think something happened in regards to the trash. I deleted a bunch of pictures off of the drive and didn’t empty the trash until way later after I’d already unplugged the drive. It’s my only guess at this point, but the hubby was tired of me jabbering about the problem and just bought me a new drive. I’m still wanting to work out the issues with the problematic drive, and will post if I get any success. Thanks for your input Gary!

    Bob Peirce
    10/31/12 @ 12:09 pm

    I have a Drobo S with 11 partitions I use for nightly backups. Three will dismount with no problems. Eight almost always give me this problem. The ONLY difference I can find (using sudo lsof) is that UserEventAgent has established a link to the Applications directory in each partition. This happens even when I logon with no apps running. This causes me to think some background assistance app automatically gets fired up when I log on and makes the connection but it is limited to eight. Unfortunately, I don’t know what is doing it or how to find it.

    I have found simply logging off and disconnecting the drive, even though sometimes I get that nasty disconnect message, doesn’t really seem to do any harm.

      10/31/12 @ 12:13 pm

      I’m pretty sure there are things from Drobo that manage the drive. That’s probably what causes it. I’d ask in their support forums.

    Breanna
    11/20/12 @ 5:53 pm

    I attempted to back up my computer using Time Machine with an external hard drive (WD My Passport for Mac 1 TB). I have other files on it but had read that you can do a back up without erasing the other files. During the back up Time Machine gave me an error saying it could not perform the backup. I then gave up and was going to unmount the disk. Now the disk won’t unmount and says it is being used by other files. I tried to do a disk utility and it says the drive needs to be repaired but then I go to do the repair it says it cannot complete it because the disk cannot be unmounted. I need the info on the drive so cannot delete and start over. I can see the folders I have on the drive but they are all blank inside and when I try to download one it gives me an error of -36. Any ideas of how I can save my drive?

      11/20/12 @ 8:40 pm

      Where did you read that? That is incorrect. You should let Time Machine take over the drive and devote the entire drive to it. There are ways to use other parts of the drive, but I don’t recommend them and most users shouldn’t do them. Not only is it not good to mess with your Time Machine backup by storing other files on it, but then those files are not backed up (think about it, logically).
      So once you get this sorted out, then erase the drive and let Time Machine manage it. Never access the drive outside of Time Machine.
      So it sounds like you’ve got some major file damage on the drive. I’d recommend taking the drive to an expert (Mac shop) and paying them to recue your files. Unless you know a thing or two it may be the only way to save those if they are important enough.

    Tim
    1/3/13 @ 2:06 pm

    I just did a force quit on Finder and then was able to eject the drive. Perhaps that is the best solution for the original problem?

    Gado
    1/10/13 @ 3:28 pm

    Thanks Tim! That was the solution for me! :)

Comments Closed.