Forum Question: Trouble with flash drive

Gary, when I insert a flash drive into my G4 (Mirror drive plates 2005), and add some files to it, it tells me: There isn’t enough room on this drive, even though it is empty! Here is the odd thing: I have to insert this drive into my iMac and add a file (any file), take it to the G4 and delete this file and empty the trash, then can I add other files. It happens to all my flash drives (memory sticks).
Only on the G4, though. The G4 runs on Leopard and the iMac runs on Snow Leopard.
—–
Joe

Comments: 5 Responses to “Trouble with flash drive”

    7/29/11 @ 9:57 am

    I wonder if your 2005 G4 is using USB 1 or USB 2. That might explain some of it.
    If the drive formatted for Mac? Maybe try using Disk Utility on that G4 and erase and re-initialize the disk as Mac format so it behaves. That would also cure any other problems in the drive.

    Joe
    7/31/11 @ 10:16 am

    Gary, a strange thing just happened! I noticed when I started my G4 just now, I got a dialog box telling me, the clock and date was off, it reported a date in 1996. I had that before, but didn’t take the time out to do something about it. This time, I reset the time/date to now. When I inserted the memory stick to download some more files, it went without the message, telling me that the disc was full. I could add files OK. Could that have something to do with the date/time?

    Joe

      7/31/11 @ 10:26 am

      I doubt it has anything to do with the date and time settings.

    Joe
    7/31/11 @ 12:29 pm

    Gary, I just wanted to prove something to myself! I shut my old G4 down. When I started it up again, that darn date/time was off again: It gave me a dialog box telling me the date/time is set to a date before 2001. I don’t know what to do about that, I did save it prier to shutting down!
    Well, before I set the date/time to the correct place, I inserted the flash drive and tried to add a file. No go! The drive is full! That pesky dialog box. I ejected the flash drive. Now, I set the drive to the correct date/time.
    Next, inserted the flash drive and tried to add a file. Success! It added that same file I couldn’t before the date reset.
    Can you believe that?!
    Now than, Gary, what’s with the date change after each shot down? Is it the battery? I didn’t disconnect the electric cord. That is another matter, help please …

    Joe

      7/31/11 @ 5:27 pm

      My guess would be that the internal battery that keeps the time going while you Mac is off is dead. They usually last around 10 years, sometimes more, sometimes less.
      You should be able to set the Date & Time preferences in System Preferences to automatically update the time. That will save you from having to do it.
      Or, just don’t shut down the Mac (sleep instead).
      Not sure why this affects the USB drive.
      Did you try re-formatting it as a Mac drive like I suggested at the start?

Comments Closed.