Forum Question: Iphone won’t delete apps! help!

Ive had this iphone 4 for a while now. and this has never done this to me. i go to delete apps by holding down the app and usually an “X” shows up and i am able to delete it. lately i have not gotten an X. All the apps shake but it is not letting me do anything but move them around and put them in folders. My phone is not jail broken. i dont know whats going on i need help!!!

Comments: 27 Responses to “Iphone won’t delete apps! help!”

    4/13/11 @ 6:43 am

    Which apps are you trying to delete? Keep in mind that the default apps — the ones that come pre-installed on your iPhone — cannot be deleted. Only apps that you install from the App Store can be deleted. It is common to have your first screen of apps be all default apps, thus you would never see any “X” buttons on that screen.

      5/10/11 @ 11:18 am

      My boyfriend phone is doin this also… The apps wont show up on itunes and there apps like facebook we kno u cant delete mail youtube or camera…ect… I press it down they shake theres no x anymore

        5/30/11 @ 8:33 pm

        My I phone4 is doing the same thing however they are not apps. They were pages that I had saved to my home screen and the X is not popping up to delete.

    Jan bergantz
    7/5/11 @ 6:53 pm

    Tried to update navgps but got stuck &won’t do anything now. Can’t uninstall &
    Won’t load!!!

      7/5/11 @ 7:53 pm

      Have you tried the basics: Restart your iPhone? Sync with your Mac/PC? Disconnect and reconnect to wifi?

        7/12/11 @ 9:57 pm

        I tried all mentioned above, and I’m not connected to wifi…

    7/12/11 @ 9:54 pm

    I am having the same problem, tried to restart, sync, nothing is working… anyone have a fix yet ? Trying to delete FB cause it’s crashing too much, “x” doesn’t pop up !

      7/12/11 @ 9:55 pm

      Have you tried to delete it using iTunes while synced?

    7/27/11 @ 3:41 am

    I’m having the same problem, even when I’m connected to the comp and try to uncheck items when the sync is done the apps are still there

    Joe NOVA
    11/8/11 @ 6:34 am

    This is very frustrating! Same as the others, my apps will shake but won’t delete. They also don’t show up in itunes.

    2/14/12 @ 5:23 pm

    Check to see if you have restrictions on Deleting apps :)

      3/15/12 @ 12:25 pm

      Yes thank you this works if u can’t get ur apps to delete and they shake but don’t have a x go to settings and disable your restrictions

        9/9/12 @ 5:30 am

        Thanks man Almost got a Samsung !!!!

        11/4/12 @ 3:43 pm

        Awesome… Worked! Now the questions is… How did restrictions get enabled?

      4/16/12 @ 11:30 am


      7/11/12 @ 2:48 pm

      THANK YOU!!

      10/18/12 @ 11:06 pm

      thank you verry much bro ur awesome good thinking u helped me alot

    3/14/12 @ 5:42 pm

    go on settings and put on deleing apps

    Sara j
    5/3/12 @ 1:35 pm

    Had the same problem…forgot that I had changed the app delete restriction. Go to settings;general;restrictions and deleting iPhone aps

      W Lewis
      9/23/12 @ 7:11 pm

      Thanks so much…this was the problem.

    6/10/12 @ 7:22 am

    I have the same problem too! When I delete the app, it will delete the app, the the box for the app is still there. And if I try to touch it it won’t let me!

    6/11/12 @ 6:13 pm

    my iphone 4 is not letting me delete the apps. unlike the other comments mine does show the X botton but it freezes up everytime i click on it to delete it. i tried reseting the phone, turning off, and nothing. also when i sync it to itunes and i click on apps they come out see through but wont let me delete it

    6/15/12 @ 8:53 pm

    I have the same problem and then remembered that I had turned in the restrictions.. Go to settings, general, restrictions, and make sure that installing and deleting apps is turned off. Simple fix for mine. Hope it helps

    7/18/12 @ 4:49 pm

    Hey guys! My problem is the same Jenny, i tried Stacey’s method but still can’t uninstall the apps. This is freaking me out!

    8/14/12 @ 2:05 pm

    My iphone 4 will not delete any app just shake no X even after I have turned all restrictions off.. Now my memory is saying it’s full and won’t receive or send txts or even let me delete emails or txts.. Tried every forum nothing to help so far. Worst phone I have had never had half as many problem with 3GS

      8/14/12 @ 2:55 pm

      Keep in mind that you cannot delete default apps. So if you happen to be looking at a home screen with only default apps (Mail, Messages, Weather, etc) then there will be no X’s. Maybe that is what you are seeing.
      Try syncing with your Mac/PC to see what might be taking up space. Probably either lots of music, or maybe you have filled it with pictures and video.

    10/5/12 @ 8:28 pm

    I just reset my network settings and everything works fine now. Problem was really frustrating though.

Comments Closed.